Ac problem and touch screen turning off and on
  1. Welcome to Chrysler 200 Forum : Chrysler 200 Forums – General discussion forum for Toyota Trucks

    Welcome to Chrysler 200 Forum : Chrysler 200 Forums - a website dedicated to all things Chrysler 200.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chrysler 200 Forum : Chrysler 200 Forums today!
     
+ Reply to Thread
Results 1 to 9 of 9

Thread: Ac problem and touch screen turning off and on

  1. #1
    Junior Member
    Join Date
    Oct 2018
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Question Ac problem and touch screen turning off and on

    Hello, I have a 2015 200. Lately my air conditioning speed will be on high and all the sudden the speed will feel like it goes down to a lower speed by itself and I have to turn if off and on to make it turn back to normal, the coldness doesn't change, just the fan speed. It is also making a weird noise. Then yesterday when I was driving my touch screen kept turning off and on when I was driving. Not sure if they were related but thought I would check here. Any ideas? Thanks for any tips.

  2. Remove Advertisements
    Chrysler 200 Forum
    Advertisements
     

  3. #2
    Junior Member
    Join Date
    Jan 2017
    Posts
    11
    Thanks
    1
    Thanked 1 Time in 1 Post

    Default

    If you have the original battery it could be causing you problems

  4. #3
    Senior Member shamrock249's Avatar
    Join Date
    Apr 2013
    Location
    Guelph Ontario.
    Posts
    733
    Thanks
    90
    Thanked 116 Times in 85 Posts

    Default

    I agree, most probably the battery. When it starts to go some weird and not so wonderful things start to happen. If it's the original have it replaced.
    2015 Chrysler 200 Ltd - Built 03/15 - Vivid Blue
    Gold plan 419 ext warranty
    3.6L
    8.4A System with Nav
    Comfort Group
    Optional 18" Satin Silver Rims with 235/45/18 Tires
    Hidden Content
    Winter Rims; Hidden Content with Hidden Content . 225/50/18
    35% Tint
    Yellow gas cap
    Added Cargo Net & Hidden Content
    Replaced the Brake Lights With Hidden Content

  5. Remove Advertisements
    Chrysler 200 Forum
    Advertisements
     

  6. #4
    Junior Member
    Join Date
    Oct 2018
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by larryl View Post
    If you have the original battery it could be causing you problems

    No, I had the battery replaced about 6 months ago so it's a new battery.

  7. #5
    Senior Member
    Join Date
    Jan 2019
    Location
    MA
    Posts
    107
    Thanks
    16
    Thanked 33 Times in 23 Posts

    Default

    If you have the climate control on Auto, it will start off driving the fan at high speed to effect cooling, and as it reaches the setting, it slows down the fan. To test if this is what you experiencing, make sure the temperature and the fan controls are NOT set to Auto, and see if this goes away.
    As far as noise, do you get a clacking or rapping noise from behind the glovebox or dash for about 10 seconds? If so, this is one of the 3 climate control motors that operates the blend door or temperature door, or recirculator door.
    Touch screen being intermittent may be a different issue.

  8. #6
    Junior Member
    Join Date
    Oct 2018
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by blincoln View Post
    If you have the climate control on Auto, it will start off driving the fan at high speed to effect cooling, and as it reaches the setting, it slows down the fan. To test if this is what you experiencing, make sure the temperature and the fan controls are NOT set to Auto, and see if this goes away.
    As far as noise, do you get a clacking or rapping noise from behind the glovebox or dash for about 10 seconds? If so, this is one of the 3 climate control motors that operates the blend door or temperature door, or recirculator door.
    Touch screen being intermittent may be a different issue.

    I don't see that I have an Auto for the climate control, where would I see that? Yes the touch screen I have no idea, it just happens intermittently and now my bluetooth won't connect at all from my phone, it just totally resets like if its on certain radio station it will restart with a different station, it's weird. Not a big deal but just hoping it doesn't lead to a bigger problem later.

  9. #7
    Super Moderator fltru103's Avatar
    Join Date
    Aug 2014
    Location
    southern New Jersey
    Posts
    1,666
    Thanks
    408
    Thanked 315 Times in 277 Posts

    Default

    Quote Originally Posted by marjam78 View Post
    I don't see that I have an Auto for the climate control, where would I see that? Yes the touch screen I have no idea, it just happens intermittently and now my bluetooth won't connect at all from my phone, it just totally resets like if its on certain radio station it will restart with a different station, it's weird. Not a big deal but just hoping it doesn't lead to a bigger problem later.
    You would know if you had the automatic temp control. That doesn't appear to be the issue.
    In my opinion, the battery or the connection at the battery, still sound like the problem to me.
    Remove the battery leads and clean each one with a wire brush, or a tool that is used to clean battery posts.
    Reattach and tighten securely those connections and start over.
    Then have the battery checked ( even though it's new ) because new can still be defective.
    Eliminate the obvious first.

  10. #8
    Senior Member
    Join Date
    Jan 2019
    Location
    MA
    Posts
    107
    Thanks
    16
    Thanked 33 Times in 23 Posts

    Default

    I agree, battery or its connections.
    Auto climate control is indicated by looking at the fan dial, if it says Auto, and if the temperature control has an Auto position, on the left.

  11. The Following User Says Thank You to blincoln For This Useful Post:

    fltru103 (07-14-2019)

  12. #9
    Junior Member
    Join Date
    Oct 2018
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by fltru103 View Post
    You would know if you had the automatic temp control. That doesn't appear to be the issue.
    In my opinion, the battery or the connection at the battery, still sound like the problem to me.
    Remove the battery leads and clean each one with a wire brush, or a tool that is used to clean battery posts.
    Reattach and tighten securely those connections and start over.
    Then have the battery checked ( even though it's new ) because new can still be defective.
    Eliminate the obvious first.
    Thank you! I will try that. I got it at Tires Plus and it was not cheap so I will be going by there ASAP.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

List your make, model & engine spec

Please select your insurance company (Optional)

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0