Radio Help!
  1. Welcome to Chrysler 200 Forum : Chrysler 200 Forums – General discussion forum for Toyota Trucks

    Welcome to Chrysler 200 Forum : Chrysler 200 Forums - a website dedicated to all things Chrysler 200.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chrysler 200 Forum : Chrysler 200 Forums today!
     
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Radio Help!

  1. #1
    Member niknak200's Avatar
    Join Date
    Jun 2015
    Location
    Brownstown, MI
    Posts
    63
    Thanks
    11
    Thanked 4 Times in 4 Posts

    Default Radio Help!

    Does anyone else have issues with static while listening to your radio? I have the typical radio in my 2013, the reception is awful while listening to regular stations. Also, I connect my phone using the input jack and again static. Not sure if any of this is covered under my warranty?

  2. Remove Advertisements
    Chrysler 200 Forum
    Advertisements
     

  3. #2
    Senior Member ChryslerCares's Avatar
    Join Date
    Jul 2011
    Location
    Aurburn Hills, MI
    Posts
    488
    Thanks
    18
    Thanked 88 Times in 67 Posts

    Default

    Hi niknak200,
    Electric/radio issues would be covered under a basic limited warranty if the root cause was determined to be a manufacturer defect. I would recommend having the vehicle looked at by your local FCA dealership to obtain an official diagnosis.

  4. #3
    Member niknak200's Avatar
    Join Date
    Jun 2015
    Location
    Brownstown, MI
    Posts
    63
    Thanks
    11
    Thanked 4 Times in 4 Posts

    Default

    Quote Originally Posted by ChryslerCares View Post
    Hi niknak200,
    Electric/radio issues would be covered under a basic limited warranty if the root cause was determined to be a manufacturer defect. I would recommend having the vehicle looked at by your local FCA dealership to obtain an official diagnosis.
    I called my dealership and they said it wouldn't be covered that its "wear and tear" issue

  5. Remove Advertisements
    Chrysler 200 Forum
    Advertisements
     

  6. #4
    Member
    Join Date
    Mar 2015
    Location
    Chicago suburbs
    Posts
    62
    Thanks
    2
    Thanked 3 Times in 3 Posts

    Default

    I call B.S. on that one... You need to take it in and get a manager in there. I've got a 2011 and the radio is just fine. Wear and tear for a radio would pretty much be limited to cosmetic things like buttons rubbed clean of labels, or usb port covers missing. Oh, also if you drove a screwdriver through it with a hammer, that would be excessive tear.
    Functionality is a whole different beast. If it was one of the old style mechanical tuning radios like we had back in the 80's then I'd say wear and tear could cause your issue. With the electronic stuff, it's all circuits and they don't wear out anywhere near that fast.

    I'd also recommend trying a different dealership if the one near you keeps giving you flack.


    -Jeff

  7. #5
    Member niknak200's Avatar
    Join Date
    Jun 2015
    Location
    Brownstown, MI
    Posts
    63
    Thanks
    11
    Thanked 4 Times in 4 Posts

    Default

    Quote Originally Posted by js5752 View Post
    I call B.S. on that one... You need to take it in and get a manager in there. I've got a 2011 and the radio is just fine. Wear and tear for a radio would pretty much be limited to cosmetic things like buttons rubbed clean of labels, or usb port covers missing. Oh, also if you drove a screwdriver through it with a hammer, that would be excessive tear.
    Functionality is a whole different beast. If it was one of the old style mechanical tuning radios like we had back in the 80's then I'd say wear and tear could cause your issue. With the electronic stuff, it's all circuits and they don't wear out anywhere near that fast.

    I'd also recommend trying a different dealership if the one near you keeps giving you flack.


    -Jeff

    I will be taking it in to a different dealership then! I called the one I bought it from so I'll try one by where I live now. Hopefully they will at least check it out! Thanks!

  8. #6
    Senior Member carguy1985's Avatar
    Join Date
    Mar 2015
    Posts
    189
    Thanks
    2
    Thanked 14 Times in 13 Posts

    Default

    I get some static but usually when i pull into the parking garage at work... that is to be expected when you are surrounded by tons and tons of steel and concrete
    2013.5 200 Carhartt Special Edition Super S'
    2012 200 S'
    Hidden Content

  9. #7
    Member niknak200's Avatar
    Join Date
    Jun 2015
    Location
    Brownstown, MI
    Posts
    63
    Thanks
    11
    Thanked 4 Times in 4 Posts

    Default

    Quote Originally Posted by carguy1985 View Post
    I get some static but usually when i pull into the parking garage at work... that is to be expected when you are surrounded by tons and tons of steel and concrete
    I would expect static at those times but mine is static almost all the time. Plus I like to plug my phone in using the aux jack and its static as well! UGH!!!

  10. #8
    Senior Member carguy1985's Avatar
    Join Date
    Mar 2015
    Posts
    189
    Thanks
    2
    Thanked 14 Times in 13 Posts

    Default

    Quote Originally Posted by niknak200 View Post
    I would expect static at those times but mine is static almost all the time. Plus I like to plug my phone in using the aux jack and its static as well! UGH!!!

    Sounds like you are getting interference form something either some frequency from the car or something you carry with you in your car.


    Some cellphones especially in extended mode change frequency and can cause static.
    2013.5 200 Carhartt Special Edition Super S'
    2012 200 S'
    Hidden Content

  11. #9
    Member niknak200's Avatar
    Join Date
    Jun 2015
    Location
    Brownstown, MI
    Posts
    63
    Thanks
    11
    Thanked 4 Times in 4 Posts

    Default

    Quote Originally Posted by carguy1985 View Post
    Sounds like you are getting interference form something either some frequency from the car or something you carry with you in your car.


    Some cellphones especially in extended mode change frequency and can cause static.

    I just have a typical iPhone, I'm gonna get it checked out never had this problem in any other car Ive had!

  12. #10
    Senior Member shamrock249's Avatar
    Join Date
    Apr 2013
    Location
    Guelph Ontario.
    Posts
    737
    Thanks
    91
    Thanked 122 Times in 88 Posts

    Default

    I've noticed recently that my radio is getting static as well. I have the 8.4A radio and for the most part I listen to the FM stations. When the radio is playing there is an 'ST' flashing beside the station number on the display. It should be crystal clear but the static is very annoying. I hate the idea of taking it to the dealer to have it checked out because of some of the stories I have read in this forum. I just don't trust them working on my car.
    Last edited by shamrock249; 12-06-2015 at 10:31 AM.
    2015 Chrysler 200 Ltd - Built 03/15 - Vivid Blue
    Gold plan 419 ext warranty
    3.6L
    8.4A System with Nav
    Comfort Group
    Optional 18" Satin Silver Rims with 235/45/18 Tires
    Hidden Content
    Winter Rims; Hidden Content with Hidden Content . 225/50/18
    35% Tint
    Yellow gas cap
    Added Cargo Net & Hidden Content
    Replaced the Brake Lights With Hidden Content

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Quick Reply Quick Reply

Register Now

List your make, model & engine spec

Please select your insurance company (Optional)

Similar Threads

  1. radio
    By jlyon in forum Chrysler 200 General Discussion Forum
    Replies: 11
    Last Post: 01-29-2016, 10:15 AM
  2. Radio removal
    By RMassa187 in forum Chrysler 200 Appearance and Body
    Replies: 5
    Last Post: 08-04-2015, 03:38 PM
  3. Radio Help!!!
    By Lynx in forum Chrysler 200 General Discussion Forum
    Replies: 33
    Last Post: 02-07-2014, 06:52 PM
  4. Radio Help, Please
    By first200 in forum Chrysler 200 General Discussion Forum
    Replies: 4
    Last Post: 04-14-2013, 01:27 PM
  5. Replies: 1
    Last Post: 05-08-2012, 10:37 PM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0