Chrysler 200 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter #1
I did the 5.0 to 8.4 swap and everything worked great. Then my screen went black, but everything worked, just couldn't access any functions. I took it to my dealer who are great to me, and they ordered and installed a replacement radio for me. The difference is that there are no icons like iheart radio or any of those or no 3g signal. is this something that can be activated through Uconnect? The problem is that they only see a 5.0 radio under my vin, so I don't get any updates anymore for maps or anything. Anyone have any thoughts?
 

·
Registered
Joined
·
3 Posts
You will not be able to receive any Uconnect Access services. The Uconnect data base will show a 5.0 Radio for your Vin. They do not update their data base to reflect changes that you or your dealer have made. Therefore you (your Vin) will not be eligible for Uconnect 8.4 services. You will not have Yelp app, iheart app etc. You will not be able to use the Uconnect 3G phone service. If you upgraded the rear view mirror, the assist and "911" buttons will not work. Your dealer will have to access software updates for You and download them. You can order Map updates by phone and hae It sent to you on a flash drive. I have a 2015 "200 Limited". It came with Uconnect 5.0. I upgraded to a 8.4AN radio and upgraded my rear view mirror to Uconnect 8.4. It took me 3 weeks of constant daily phone calls with Uconnect Customer Care to find out what was going on. Wish I had better news för you. Hope you make out better tähän me.
 

·
Registered
Joined
·
27 Posts
Im not sure why your functions are not working, perhaps you have something wrong internally. I would recommend a reset of the radio and see if it works. I did the swap from 5 to 8.4a and i got rear view mirror too and it works except doesnt have auto dim. The uconnect phone and text features work but i dont have access to any apps.
 

·
Registered
Joined
·
36 Posts
Same here. I have nav and calls, text, but also weather alerts, movie listings, sports team updates, etc. No other apps though. Love the bigger screen, so many dealerships tried to tell me it couldn't be done! (Upgrading from 5.0 to 8.4). Among best $600 I've spent!

QUOTE=Lazer20000;643868]Im not sure why your functions are not working, perhaps you have something wrong internally. I would recommend a reset of the radio and see if it works. I did the swap from 5 to 8.4a and i got rear view mirror too and it works except doesnt have auto dim. The uconnect phone and text features work but i dont have access to any apps.[/QUOTE]
 

·
Registered
Joined
·
169 Posts
Discussion Starter #6
Im not sure why your functions are not working, perhaps you have something wrong internally. I would recommend a reset of the radio and see if it works. I did the swap from 5 to 8.4a and i got rear view mirror too and it works except doesnt have auto dim. The uconnect phone and text features work but i dont have access to any apps.
Thanks for the reply, how do I reset the radio? Do I lose all the stored info if I do this?
Thanks
 

·
Registered
Joined
·
3 Posts
If you do a radio reset you will lose all stored information (ie. Favorites, home address, etc). The software and maps should not be impacted. A factory radio reset did not solve any of my issues. Good luck.
 

·
Registered
Joined
·
27 Posts
To reset the radio you have to enter the engineering menu. You have to hold the drivers temp up and temp down (or just up and down if you only have one set), and the front defoster for about 5 seconds..engineering menu will pop up. It should be under RTN i think. It will be factory radio reset. You will lose all settings and favorites.
 
1 - 8 of 8 Posts
About this Discussion
7 Replies
4 Participants
Lazer20000
Chrysler 200 Forum
We’re a forum community dedicated to Chrysler 200 owners & enthusiasts. Come join the discussion about reviews, maintenance, upgrades, and more!
Full Forum Listing
Top