Chrysler 200 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
So this happened several months back and turning the car off and back on fixed it. This time, nothing I've done has fixed it.

I'm driving to work this morning with the AC and recycle air blowing on me at the coldest. I press the button to turn the air up a bit and this switched the AC and recycle off and moves it to defrost. Turn off defrost and it moves it back to AC/Recycle and blowing on me. Ok, turn off AC > switches it back to defrost. Turn off defrost, back to AC. Turn off recycle air > back to defrost. Every button turns on something else and back again. I've turned off the air, I've restarted the car several times once I got to work. I'm not sure what else to do or what's causing this.
 

·
Super Moderator
Joined
·
2,403 Posts
I hate to suggest this again for an electrical problem but, this car can have strange electrical issues if the battery is weak.

Have you had the battery load tested?

Have you disconnected the battery for 10 minutes - reconnected it and then tried it? TIP: if you do this don't lock the doors first, you don't want the alarm to sound when you re-connect the battery unless you like being startled.

I had a problem with my entire instrument panel going dead - tach and speedometer, fuel etc... not working. After I replaced my battery the problem NEVER returned.
 

·
Registered
Joined
·
281 Posts
I like your avatar pic! Its my background on my phone. Like BK said, have your battery load tested 1st. These cars act weird when its getting weak. If its the original Ill bet thats the prob!
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
3 Participants
Sleeper200c
Chrysler 200 Forum
We’re a forum community dedicated to Chrysler 200 owners & enthusiasts. Come join the discussion about reviews, maintenance, upgrades, and more!
Full Forum Listing
Top