Chrysler 200 Forum banner

21 - 25 of 25 Posts

·
Moderator
2016 Chrysler 200 S, 1998 Sebring JX
Joined
·
637 Posts
I think of the AGS module as a slave unit or servo. The PCM is in charge of the decisions and initialization command at startup. The LIN bus wire is mainly 'feedback' to tell the PCM where it is at and to receive commands.
Interrogating the PCM may be more helpful. If the PCM doesn't see the AGS, it will default to full cooling for protection.
The initialization command resides in the PCM. If the PCM thinks that things are too warm or max A/C is needed, it will go to full open grille and high fans.
A scan tool that can see inputs/outputs, sensor states and manually actuate the AGS open or closed may be useful.
How are you erasing the code? A battery disconnect may not erase it from memory and a tool may be necessary to force a code erasure.
 

·
Super Moderator
Joined
·
2,616 Posts
Discussion Starter #22 (Edited)
How are you erasing the code? A battery disconnect may not erase it from memory and a tool may be necessary to force a code erasure.
This is how I have been erasing the codes (3 of the same code). CEL comes back on after one cycle, meaning I clear the code, start it fan turns on full blast after maybe 2 minutes but CEL is off. CEL turns on when next started.

57004


I get what you are saying, but could it be a broken wire within the stepper motor? One of the steps is to test with a "known good" AGS - unfortunately I don't have one.
 

·
Moderator
2016 Chrysler 200 S, 1998 Sebring JX
Joined
·
637 Posts
If the wiring between the PCM and AGS is OK, I would more suspect the AGS actuator than a PCM.
I don't know if any salvage yards might have a good used one. It may be considered a 'crash part' and in high demand. The part # is 68200289AA.
If it can't return information back to the PCM, the PCM will default to full cooling. It also may not be able to initialize at power-on.
You could remove and open up the AGS to look for obvious corrosion or broken wires. I don't know what other diagnosis you can do at this point.
 

·
Super Moderator
Joined
·
2,616 Posts
Discussion Starter #24
Overdue update. It's fixed. I finally just had everything besides the new tires I bought for it replaced on August 10th. 😎

57128


I traded it in and as part of the deal they put the tires from my 200 on the new (used) Ford at no additional charge. Got it from the same dealer I bought my last 3 brand new Chrysler 200's.
 
  • Like
Reactions: fltru103

·
Registered
Joined
·
9 Posts
Hey there
So how did you solve the problem
Because I have exactly same issue with my 2015 Chrysler 200
Thanks
Let me know please
 
21 - 25 of 25 Posts
Top