Chrysler 200 Forum banner
221 - 236 of 236 Posts

·
Registered
Joined
·
4 Posts
I got a Chrysler 200s 2015 would a audio control lc2i does it sound good in a Chrysler 200s with a addictive audio 200.1 amp and a 4 sundown 8s custom Birchwood box wat best thing to do to get best sound without upgrading the uconnect 5.0 radio at moment
 

·
Registered
Joined
·
4 Posts
Questions about front dash and front door speakers.
I’m curious to know what type of speakers are in the dash of the 10 speaker Alpine system. I see a lot of people referring to them as tweeters, but they are 3.5 inches wide and when I fade everything to the front, it seems they are putting out a little more than just a straight tweeter would. I was wanting to start by replacing the three dash and two front door speakers to see if I could get a little better sound out of the system. I removed all three dash speakers and the right and left have the same part# on them, but the middle one has a different number. I took turns plugging in the center speaker where the left dash speaker should go and then plugging the correct speaker back in trying to find a difference in the sound. They sounded exactly the same,so I don’t know. I’ve read the alpine amp sends a high signal to the dash speakers, so I was thinking of just buying some nice low impeadance tweeters for the left and right,but I’m not sure what to do with the center speaker.
After all of that, I unplugged all 3 dash speakers so I could listen to the front door speakers and they are definitely getting a low end signal with barely in vocals discernible. Again I was going to try to find some low impeadance 6 x 9 mid range speakers to swap these out. Any thoughts? Again, I’m not prepared to go any farther than the 5 speaker swap and will be happy with a small improvement. I’ll include pics of the speakers I pulled.
 

Attachments

·
Premium Member
Joined
·
1,820 Posts
Discussion Starter · #224 ·
If you want to improve, get a component kit with 6.5 round speakers for the front and 1 inch tweeters for the left and right dash speakers. Do Not change the center one, it is calibrated to produce the best output for incoming calls, anything else that I tried was lowering the sound quality of incoming calls.
 

·
Registered
Joined
·
11 Posts
I have the 2015 200c with the 8.4 uconnect and factory amp. I want to hook up am aftermarket amp and subs keep mu uconnect. I know hpw to do it as i did it in my 2014 cherokee that also had the 8.4 the only difference being my jeep didnt have a factory amp. So my question is in my 200c would i have to bypass the factory amp or can i just hook up my line out converter right into my factory sub wires and get my rca signals through there. Im extremely lost and cant find squat online pertaining to this
 

·
Registered
Joined
·
45 Posts
Any news on getting highs out of the front door speakers? I recently replaced all speaker "not the 3 front dash" and I'm getting only lows level out of the front door 6x9 which are 3 ways. I was hoping replacing them with better 3 way 6x9 would give me the highs I wanted. I barely hear anything coming from them.
 

·
Registered
Joined
·
128 Posts
I have wanted to do this for a while but I redid my audio build.
I went full active in the front with custom a pillars. The a pillars were built by a local shop. I went with a DC XL Elite with a ported box that I built with a plexiglass window.
My bass amp is a wolfram 4500.1 wired to 2 ohms. This is a bad ass amp that i used an o scope and I got close to 3k watts at 2ohms. I wired in 2 more batteries in the spare tire spot. I could not get to the spare tire anyway, I also deleted the rear deck speakers.
56553


56549
56550
56551
56552
 

·
Registered
Joined
·
11 Posts
I have wanted to do this for a while but I redid my audio build.
I went full active in the front with custom a pillars. The a pillars were built by a local shop. I went with a DC XL Elite with a ported box that I built with a plexiglass window.
My bass amp is a wolfram 4500.1 wired to 2 ohms. This is a bad ass amp that i used an o scope and I got close to 3k watts at 2ohms. I wired in 2 more batteries in the spare tire spot. I could not get to the spare tire anyway, I also deleted the rear deck speakers. View attachment 56553

View attachment 56549 View attachment 56550 View attachment 56551 View attachment 56552
those A pillars look amazing/ my buddy has the same set up but in his doors and has been thinking about doing the apillars. the hertz milli legends sounds amazin . I just installed the same xs power battery in my car.
 

·
Registered
Joined
·
3 Posts
If you want to improve, get a component kit with 6.5 round speakers for the front and 1 inch tweeters for the left and right dash speakers. Do Not change the center one, it is calibrated to produce the best output for incoming calls, anything else that I tried was lowering the sound quality of incoming calls.
If you want to improve, get a component kit with 6.5 round speakers for the front and 1 inch tweeters for the left and right dash speakers. Do Not change the center one, it is calibrated to produce the best output for incoming calls, anything else that I tried was lowering the sound quality of incoming calls.
Hey fern I seen a earlier post you put T165s in your 200 did you have any problems installing them. I ask because Crutchfield site says they don’t fit
 

·
Registered
2015 Chrysler 200 S, 2.4L FWD
Joined
·
4 Posts
has anyone had issues with lights dimming after upgrading the ECU ground to a larger gauge? i plan to replace due to its size and appearance as speaker wire, but im curious

i was running into grounding issues where i was actually missing a ground and the car was grounding through the rack and pinion which ended up blowing out my power steering (replaced under warranty) other issues around the same time suggest some power was grounding thru the ecu as well and shorting out certain components... anyways i added an extra ground from my amp as well as one between the battery and engine (when doing big three/four the battery and engine ground are connected to ground through a harness and both sides need to be replaced).

i have hi output alt (powerbastards), all 0 gauge wires to power and ground my subs i think i used 8 for the speaker wire itself. i have a capacitor on standby and an accessory battery on hold but the dimming has been reduced by what id already done so significantly i am hoping i can go the less time consuming route. Or at least see if someone has done it yet for this reason
 

·
Registered
2015, Pensatar 200c AWD
Joined
·
15 Posts
Hey guys,

I know a couple of you worked on changing their speakers and adding amps to their cars (Saspring is one of them). I spent the day at my audio shop today installing my aftermarket speakers and amp and we ran into an issue that we didn't manage to solve today. We have different options to fix it but I want your advice first.

Here's the issue: It seems like 2 signals come out of the radio, one is full range and the other is just for the highs. Once that those 2 signals get to the Alpine amp, it looks like a full range signal goes to the rear 6X9 and then a high signal goes to the dash's tweeters and a low signal goes to the door's speakers. Is there a way or a device that exists that can sum the highs and lows that are sent to the front (dash and doors) together? Because otherwise, once it gets to my AudioControl module, only highs are sent back to the front and the sound really sucks.

One of my options is to switch my 360/4 channels amp for a 6 channel amp. This fixes my issue but costs me more money

Option number 2 is to tap into the rear speaker's full range signal and use this signal to send to my amp and then back to the front speakers but this option makes me lose the "fade"option of the Uconnect system, I can go from left to right but I can't fade only the rears or the fronts anymore. This is a minor issue and is the solution that we are looking into.

Option 3 is if one of you can explain us how the signal is sent from the radio to the Alpine amp first and then from the Alpine amps to the speakers. Then if their is a misunderstanding on our part, we can fix it and get it to work without too much work.

I took a lot of pictures of the install and could do a tutorial once my issue is fixed.

Any help appreciated.
Mine ( 2015c )has the Alpine upgraded stereo system, factory deck. I wanted to install a sub and an amp They just ran RCA's and converted off of the open air factory 8, disabling that in the back deck. We ran the amp straight off the speaker outputs for that with the conversion kit and it's worked perfectly for me. My amp is 600 w and the factory amp from Alpine is 500 That's really the limit of power draw without changing the alternator out.
 

·
Registered
Joined
·
2 Posts
Hi everyone,

I am trying install my subwoofer amp. I just have one question. Is it ok to put the ground wire on the top beam just under the rear deck? I'm a little hesitant to drill on the bottom as may hit the gas tank. I know I'll need to clear away the paint and what not.
Hood Automotive lighting Automotive tire Blue Tread
 
221 - 236 of 236 Posts
Top