Chrysler 200 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
First real post. WOO-HOO.

check it out, i've been going crazy over the fact our 8.4 RA4's dont support android auto and car play. i believe this is from hardware limitations i've read somewhere through the grape vine. Though don't quote me.

What i've done is looked at all 2018+ MOPAR's with a uconnect 4C unit and noted the mounting holes..

Naturally our big brother 300's would be a first choice in an assumption of a direct swap being possible... think again :p

I've concluded there is no possible way for us to mount these units without slight modifications...

I've bit the bullet and purchased a 2018 Jeep grand cherokee Uconnect 4C QAS (W/ NAV) from a salvage yard. The Harness is identical due to previous research and comparisons online... so naturally being excited i've ripped apart my poor baby and plugged this sucker in.. ill post pic's and comparisons of both units and post now...
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Old unit out. New unit in... it's incredibly responsive and works flawless with the HVAC and GPS.

that's where the fun ends....

No sound!
No SXM icon!
Car will not accept a PROXI alignment with this unit installed. im not sure if i need to add a sales code or what.. AlfaOBD spits an error for an entertainment telematic module and dumps the PROXI. old unit back in and PROXI succeeds no issue.

What do we know?


-Unit somewhat reads BCM. First boot on new unit showed a JEEP splash screen. shut off, wait, and cylcling the ignition turned the unit into a "chrysler" uconnect with the blue theme and splash screen.

-Unit is seeming to not receive the BCM config as the SXM icon never does show up even after 4 30minute drives and 2 work shifts in between.

-AlfaOBD spitting somesort of 'ECU config mismatch' error. I will record the codes tomorrow while i fiddle with stuff and stare at it hoping pixi dust will make it function flawlessly.


The no sound really bothers me i wonder if this is a pin mismatch on the harness or a canbus issue. I'm obviosuly not an expert but i'd imagine the CANBUS would only tell the vehicle amp to power on and could only guess the uconnect system delivers low level signals to said amp. anybody with the base package audio know how this works? Does the base package even have an external amp? I have the Alpine system in mine....

Door chimes DO work, and oddly enough handsfree callling works. Nav turn by turn lady speaks to me oh so kindly as well....

Sorry for the poor sentence structure. never really finishes school and never did quite learn on how to properly write presentable articles of text.

What do you guys think?

Seems to me ill have to play with the BCM config and find a lucky combination of settings.
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Sorry to bring this post back from the dead I’m just curious if you ever got the 4C unit working this is something I’ve wanted to do with my car as well
Unfortunately I've given up hope. I've fiddled with BCM configs and just can't get it to complete a PROXI alignment. I have a funny feeling it has something to do with my vehicle having the factory alpine system.. they just won't talk to eachother... Perhaps the CANBUS messages are different. I wish I knew and I wish I had sound with the unit installed or else I would roll with it...
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Sorry to bring this post back from the dead I’m just curious if you ever got the 4C unit working this is something I’ve wanted to do with my car as well
Unfortunately I've given up hope. I've fiddled with BCM configs and just can't get it to complete a PROXI alignment. I have a funny feeling it has something to do with my vehicle having the factory alpine system.. they just won't talk to eachother... Perhaps the CANBUS messages are different. I wish I knew and I wish I had sound with the unit installed or else I would roll with it...
 

·
Registered
Joined
·
75 Posts
That's too bad you couldn't get it working. It would be nice if FCA had decided to sell an official upgrade kit for the 200, I'm sure they'd rather sell us new cars but an upgrade would still make them some money (besides, if I buy a new car it won't be an FCA product, they've discontinued anything I might want to buy). Oh well, looks like aftermarket is the way to go to get Carplay and Android Auto in the 200,on the plus side though some aftermarket head units have wireless Carplay while Uconnect does not.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
That's too bad you couldn't get it working. It would be nice if FCA had decided to sell an official upgrade kit for the 200, I'm sure they'd rather sell us new cars but an upgrade would still make them some money (besides, if I buy a new car it won't be an FCA product, they've discontinued anything I might want to buy). Oh well, looks like aftermarket is the way to go to get Carplay and Android Auto in the 200,on the plus side though some aftermarket head units have wireless Carplay while Uconnect does not.
Indeed it's a real shame... My hope is that Products one day populates with a 4C upgrade. If this vehicle had that radio for upgrade I would most likely keep her until the wheels fell off.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
hi again everyone,

this is an interesting read check it out


a rasberry pi intercepting the canbus messages between the unit and BCM.

so in theroy if we can fool the BCM in thinking the uconnect 4C unit is the same as whichever unit is in the vehicle all should be good.

so from what i've gathered in all this research over the months is this;

-as far as i can assume the bcm just wants to know what radio this is and what audio system option is installed in the vehicle so it can tell the unit to either have its wires on the harness be speaker outputs with the units internal amp or those same wires can become a line out for an external amp for premium audio.

- in my experience with the app "alfaOBD" (google it it's great) the system info populates with an, "ISO CODE: 000000" when all other modules in the vehicle show "ISO CODE: 20202020"
i thought that was interesting and also bcm was showing those module mismatch errors

- research taught me in order to upgrade an aspect of the vehicle we need to add a sales code in Witech. apperantly the sales code that can be added can only have been released with that series vehicle (ie i cant add the sales code for beats audio from a 300, or the UAS UAQ designation for uconnect 4c which was not released for our vintage of model) now this sales code when added needs to be uploaded to some fancy chrysler server and the witech software will give you a new vehicle config data file which you download and will then let you complete your PROXI alignment successfully (hence my failed PROXI no matter what bcm config option i tried because the car simply doesnt know what this unit is)

that's all i can think of for now feel free to give input or correct me if you have more knowledge of anything i mention.
I think it's time to research what these canbus messages look like and how to convert the, ' old language to new language'
Also curious as to when the vehicle "self tests" for lack of better words and broadcasts to see which modules are installed and how we can intercept that message so our vehicles think our old uconnect radio's are installed, that should bypass the need for a proxi.

cheers guys,
Keven
 

·
Registered
Joined
·
4 Posts
I think the Compass MP or Renegade Uconnect unit would have better chance to speak with the Chrysler BCM as they use the same BCM. The Grand Cherokee does not. This is assuming, it not sure this would work. But in theory the Compass and Renegades are better donor. As they use the same platform?
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter #14
I think the Compass MP or Renegade Uconnect unit would have better chance to speak with the Chrysler BCM as they use the same BCM. The Grand Cherokee does not. This is assuming, it not sure this would work. But in theory the Compass and Renegades are better donor. As they use the same platform?
absolutely. i've always wondered what that whole powernet thing meant in alfaOBD.
Also curious about the differences between the old ,"dodge wiring vs fiat wiring" as i've read amongst a few mopar based forums. canbus pinnout are identical between the grand cherokee doner and my vehicle confirmet by Mitchell's prodemand
Nice observation shadow. You've got me itching to source one.
 
1 - 14 of 14 Posts
Top