Chrysler 200 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
  1. I recently replaced a bad actuator in my 2013 200S about a month ago. The other day I started to hear 2 of them clicking. They will even click if I just open the passenger side door! I have to continually press the recirculation button for ruffly 5 minutes before it stops for awhile. Any help would be Great.
 

·
Registered
Joined
·
7 Posts
Idk much about the 200 Brown Bear as I just got mine on December 2nd. However, your prob sound similar to what I had on my '11 Charger RT+. I couldnt get the Recirculation to activate. after a meet with the other Dodge Fanatics at the Walmart p-lot, I replaced the actuators, to no avail.
Later I learned that the 2bit used car lot I got the car from had let the battery die. Not only did the vehicle lose the tune the 1st owner did, the actuators were good, the ECU didnt know where closed or open was.
so i had to drop it off for several days at the Dodge Dealership and my ECU had to re-learn when to shut off the actuators at closed, and also when to shut off when it reached open. You may not have to go this $250 route tho, on the charger forums some Mopar Owners didnt have this problem after replacing the actuators. the 2011 Charger is glitchy like that.
hope this helps, but always fact check and get a 2nd opinion from your neighborhood gearheads. if you dont know any, go to your local track.

btw, do you have Dual Climate Zones? i have only heard of this actuator prob on DCZ equipped Dodge/Chrysler vehicles.
 
1 - 2 of 2 Posts
Top