Chrysler 200 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Anyone have any idea how to get my turn signal passenger side rear to turn off? It’s not flashing it’s just on as if it’s a lamp and won’t turn off, even with the car off and lights switched off. The brake lights work fine and as normal but the tail light turn leds won’t turn off so I had to unplug the cable in the light housing so I didn’t kill my battery at work. I called chrysler and they said they’ve never heard of it and I’m not wealthy enough to have them try and diagnose and fix it.
Any suggestions towards a solution would be extremely appreciated!


56719


My fb post with video and more photos & info
 

·
Moderator
2016 Chrysler 200 S, 1998 Sebring JX
Joined
·
508 Posts
Have you tried cycling the hazard (4-way) switch a few times? Does the button latch and release OK? Try unplugging the multifunction switch in the column?
If you have a wiring diagram, try disconnecting the Rt. rear lamp driver at the TIPM for diagnosis?
The TIPM and cluster (CCN) may store helpful fault codes.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Yeah nothing worked. A while after I kept getting angry having to disconnect the light and re connect it when parked and I did it pretty rough and it went off and has worked correctly since. Still unknown to what made it stay on
 

·
Registered
Joined
·
532 Posts
Yeah nothing worked. A while after I kept getting angry having to disconnect the light and re connect it when parked and I did it pretty rough and it went off and has worked correctly since. Still unknown to what made it stay on
Garye332,
We are happy to hear your concerns have been resolved. If you ever have any vehicle questions, please don't hesitate in reaching out to us via private message.

Alex
Chrysler Cares
 
1 - 5 of 5 Posts
Top