Chrysler 200 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I just purchased a 2012 200 Hardtop convertible. The uconnect center radio will not make a sound in AM mode. Some local FM stations play but the scan and seek buttons spin but will not lock on anything. I have been 2 days trying to figure it out. Donwloaded the manuals but still didn't get t.
 

·
Super Moderator
Joined
·
1,858 Posts
I just purchased a 2012 200 Hardtop convertible. The uconnect center radio will not make a sound in AM mode. Some local FM stations play but the scan and seek buttons spin but will not lock on anything. I have been 2 days trying to figure it out. Donwloaded the manuals but still didn't get t.
Welcome to the forum finnhensley !
Sounds like a weak antenna signal. Have you checked those connections ?
 

·
Registered
Joined
·
7 Posts
I am following your post in hopes someone posts some advice. I have a 2015 hardtop and am also having trouble with the radio. While under warranty, my radio was replaced twice due to issues with both the radio and the navigation system. At the time, the dealer mentioned many of the radios were having to be replaced, because as i recall, I had to wait a bit for a new radio to come in, they were back-ordered. So now I am out of warranty, and the radio is not coming in. Navigation works fine, but virtually no reception on radio; one station comes in just a bit. Also, the reception seems to come and go. One time it came back fairly strong for awhile, but then petered out again. I have checked my antenna to be sure it is properly screwed on. I am assuming it is some sort of wire that has a bad connection? But I am just an average car owner, and know absolutely nothing about auto repairs, so I am at the mercy of the shop. I've been curious if others are having issues,so I will follow your thread.
 
1 - 3 of 3 Posts
Top