Chrysler 200 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,
I’ve browsed around the forum, but couldn’t find exactly what I’m experiencing. I have a 2015 C, with the 2.4 liter engine. Is it normal/does anyone else have an extremely tough idle? The steering wheel shakes so bad at an idle, either at stop lights or in park. Once you accelerate it’s smooth other than the jerky transmission. Any ideas or feedback would be greatly appreciated!
 

·
Premium Member
2016 Chrysler 200 S, 1998 Sebring JX
Joined
·
264 Posts
Is it rough when warm also? Is it rough like a misfire, or just a slow idle?
TSB # 18-083-18 addresses a cold rough idle.idle flare and idle surge issues. I would start here:
It should still be covered if you are under 80K miles.

The TCM update 21-001-18C to address shift quality should be performed at the same time:
Have them perform a PROXI alignment check and Quicklearn after the TCM flash.
 

·
Registered
Joined
·
530 Posts
Hello,
I’ve browsed around the forum, but couldn’t find exactly what I’m experiencing. I have a 2015 C, with the 2.4 liter engine. Is it normal/does anyone else have an extremely tough idle? The steering wheel shakes so bad at an idle, either at stop lights or in park. Once you accelerate it’s smooth other than the jerky transmission. Any ideas or feedback would be greatly appreciated!
Hi whiteley03,

We're sorry to hear of your vehicle concerns. If you are unable to receive more feedback from here, please feel free to contact us via private message as we'd be glad to look into this further.

Alex
Chrysler Cares
 

·
Registered
Joined
·
2 Posts
Hello,
I’ve browsed around the forum, but couldn’t find exactly what I’m experiencing. I have a 2015 C, with the 2.4 liter engine. Is it normal/does anyone else have an extremely tough idle? The steering wheel shakes so bad at an idle, either at stop lights or in park. Once you accelerate it’s smooth other than the jerky transmission. Any ideas or feedback would be greatly appreciated!
I had both motor mounts replaced at 30K--stopped the shaking.
 

·
Registered
Joined
·
17 Posts
Hi! I posted something similar ( i believe in general ). Still unsure what it is and I have passengers comment on it as well. I feel vibrations in steering wheel as well.

Hoping its something simple like the motor mounts and not a more serious problem
 

·
Super Moderator
Joined
·
1,903 Posts
The OP stated he has the 2.4 engine. How many miles are on that vehicle ?
My first suggestion would be to replace the spark plugs. The car is 5 years old, the plugs have a lot of time and mileage on them.
My wife's 200 ran fine, but I replaced the plugs around 95K. Afterward the engine felt smoother.
Recommended replacement at 100K. If your near that, replace them. It will make a difference.
 

·
Registered
Joined
·
17 Posts
Just as an update for the OP. The mechanic confirmed it was 1 of my motor mounts. Getting it fixed next week. Will update once the new ones have been installed in the upcoming week.
 

·
Registered
Joined
·
17 Posts
Final reply. Got it replaced with the OEM mount. Costed around $400. Got back in my car, started it up, felt like an entirely different vehicle. Smooth like butter.

Just as an update for the OP. The mechanic confirmed it was 1 of my motor mounts. Getting it fixed next week. Will update once the new ones have been installed in the upcoming week.
 
1 - 9 of 9 Posts
Top