Chrysler 200 Forum banner

1 - 20 of 209 Posts

·
Registered
Joined
·
562 Posts
Discussion Starter #1 (Edited)
Didn't see it specifically in any other threads...but think it might be a good idea to one thread dedicated just to Uconnect Updates come out since they do not really have any advance notification.


Just checked today and seems a new one was released : Dec 18th 2014

Includes:

This update contains the following improvements and or additions:
-Enhanced performance in Navigation, HD radio, AM/FM sound quality, and Voice Recognition
-Enables VIA-Mobile (for customers running software prior to 13.48.3)
 

·
Registered
Joined
·
133 Posts
is that 14.47.1?
I've been running that 47.1 for a few days and it seems my HD Buffering has reduced and also added an aux input level adjustment in audio settings. Also some additional changes i can't recall at the moment.
I think that is the newest update for the 8.4" radio

as for the smaller 5" radio, I'm not sure what releases they have

Previous sw version was 14.35.0 which if i remember correctly came out August/September time
 

·
Super Moderator
Joined
·
1,820 Posts
UCONNECT® 8.4A_RA3_14.47.1_MY15 is the latest update for mine but as for the previous one, I am not able to download it from home. Tried from IE, Google chrome, Safari, nothing works, Akamai tool installs then nothing happens. I tried disabling my firewall, antivirus, popup blocker, still a no go...As I said in the other post, as for the previous update, if anyone can make it available on a dropbox or something, I am a taker.
 

·
Registered
Joined
·
191 Posts
Just updated today and it went smoothly. Not driving until tomorrow so I cannot comment on anything being different.

For those new to updating:
1. Use either Internet Explorer or Safari (if on a Mac), make sure you check to see if you get any blocked content as you need to enable it
2. You must go to the site, input the last 8 of your VIN and go through the tutorial for updating
3. At the end, you download and install Akami Net which is the stupid thing Chrysler decided to use to download the update
4. For me, I had to reset my computer after the install of Akami Net and go back to the uConnect page, where you will have the option to skip the tutorial and download the update file
5. When the update file finishes, the installer will launch, you want to extract it to the file to the COMPLETELY EMPTY, at least 4GB, flash drive
6. When the extraction finishes, keep the engine off but turn the car on
7. Once uConnect initializes, put the flash drive in and if you did everything correct, the system will prompt you with an update screen, it will show your current firmware and the firmware on your drive
8. Hit ok if you want to update and let it do its thing, you need to keep the car on, but there aren't any additional actions you have to take once the update begins, it will take about 15-20 minutes and once its done you it will reboot and again prompt you for the update, but you can remove the drive and turn the car off.
 

·
Registered
Joined
·
20 Posts
I've tried this and the previous download from several computers, and I can't get this Akamai thing to work. Some kind person offered the September .iso file for download. It would be great if someone would do that for this one.

Having said that, I found a link to download this file from a Dodge Challenger forum. The file has the same name. Is it the same .iso, and will it work for our 200s?
 

·
Registered
Joined
·
562 Posts
Discussion Starter #9
I've tried this and the previous download from several computers, and I can't get this Akamai thing to work. Some kind person offered the September .iso file for download. It would be great if someone would do that for this one.

Having said that, I found a link to download this file from a Dodge Challenger forum. The file has the same name. Is it the same .iso, and will it work for our 200s?
It is not your computer...but your browser. Currently on a Mac...and Chrome did not work but on the same computer, FireFox did.

I'd suggest playing around with your browsers/settings before trying a different model file.
 

·
Registered
Joined
·
20 Posts
I finally got this to download on the Mac in my office. I couldn't get this Akamai software to install on any other computer. No clue why not, but it isn't browser settings, it's something with the software installation.

Also, I ran an MD5 on the file from the other thread and the one I downloaded, and they are, indeed, the same file.

Here is a link to the one I downloaded for anyone who might need it: https://www.dropbox.com/s/3kediyr2mdug0kd/MY15_RA4_14_47_1_NAFTA.zip?dl=0

The MD5 of the .iso file that this .zip contains is 1207a85f13c0223fa5449e9937a196a4.
 

·
Registered
Joined
·
562 Posts
Discussion Starter #11
No clue why not, but it isn't browser settings, it's something with the software installation.

It is something with your browser settings since I got the program to download from FireFox (but not Chrome) on the same MacBook Pro...3 minutes apart.

Glad though you found another workaround.
 

·
Registered
Joined
·
95 Posts
I have to say that this update did wonders for my sound quality. Couldn't imagine a software update could have that kind of effect. Before the upgrade the bass in the car had me constantly playing with the equalizer and never happy. I was even ready to start replacing speakers and amps. With this upgrade I am more then happy happy with the sound quality. Anyone else notice this?
 

·
Registered
Joined
·
829 Posts
I have to say that this update did wonders for my sound quality. Couldn't imagine a software update could have that kind of effect. Before the upgrade the bass in the car had me constantly playing with the equalizer and never happy. I was even ready to start replacing speakers and amps. With this upgrade I am more then happy happy with the sound quality. Anyone else notice this?
All I noticed was that the update reset my equalizer settings to 0 and turned off surround sound, so music didn't sound as good. Turned on the surround setting and reset the equalizer (slight bass boost) and it sounds about the same as before to me. This is for .mp3s from a USB drive. I don't listen to the radio enough to notice if there was any change in it's sound quality.
 

·
Registered
Joined
·
1,576 Posts
All I noticed was that the update reset my equalizer settings to 0 and turned off surround sound, so music didn't sound as good. Turned on the surround setting and reset the equalizer (slight bass boost) and it sounds about the same as before to me. This is for .mp3s from a USB drive. I don't listen to the radio enough to notice if there was any change in it's sound quality.
So this really only updates the mp3's? I wonder since I've been using wma formatting of my music rather than mp3's.
 

·
Registered
Joined
·
829 Posts
So this really only updates the mp3's? I wonder since I've been using wma formatting of my music rather than mp3's.
No. I was only stating what format the music I listen is in, and that the update apparently (to me) does not change the sound quality for that format.
 

·
Registered
Joined
·
562 Posts
Discussion Starter #16
Minor update (to the Uconnect website itself):

It does now appear when you put in your VIN, it automatically now has a pop-up telling you if your system is up-to-date or not.

Before it would just tell you what the most current version was.
 

·
Registered
Joined
·
153 Posts
Minor update (to the Uconnect website itself):

It does now appear when you put in your VIN, it automatically now has a pop-up telling you if your system is up-to-date or not.

Before it would just tell you what the most current version was.
Nice catch. That's one thing I like about Ford's site. When you login to your my ford page right on the front it tells you if you need an update or not.
 

·
Registered
Joined
·
201 Posts
Ok I got this to download finally using IE.

I downloaded to the empty flash drive and then extracted it there also and ended up with two files on the drive:

The My_15Ra4 file and a .iso file called SWDL that is about 657 MG.

Is that all I should have after It's extracted?

Also I formatted the drive to NTFS instead of Fat 32, would that make a differance in using it in the Uconnect system?
 

·
Super Moderator
Joined
·
1,820 Posts
Ok I got this to download finally using IE.

I downloaded to the empty flash drive and then extracted it there also and ended up with two files on the drive:

The My_15Ra4 file and a .iso file called SWDL that is about 657 MG.

Is that all I should have after It's extracted?

Also I formatted the drive to NTFS instead of Fat 32, would that make a differance in using it in the Uconnect system?
Yes all you need is the iso file on the drive...It will boot itself once inserted.
 

·
Registered
Joined
·
201 Posts
cool thanks
 
1 - 20 of 209 Posts
Top